Troubleshooting

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ID

Error Code

Issue Description

Solution

Cloud

Based

Card

Errors

ANF

Account not found

Bind the card to the account. You can follow one of the two ways to fix the issue:

1) Vendor admin can go to vendor portal -> User Management. Locate the customer info and click on “Edit”. Then enter the laundry card number # and click to save changes.

2) The customer can open Cleanpay Mobile app -> Account -> Update Laundry Card. Enter the LC number and CVC (that can be found at the backside of the card).

E001

Get price failed

1. Check if the cloud card is bound to the account

2. Check if the account is registered

E002

Deduct money failed

1. Check if the cloud card is bound to the account

2. Check the third-party response log

E003

Start failed

Automatic reversal, nothing needs to be done

E004

Start time out

User needs to start machine within 1 minute of successful payment, some may require within 90 seconds

Note: “E004” will be displayed at the terminal side, while “Start Failed”/”Can’t Start Machine” will be shown on mobile app.

E005

Price changed

Automatic reversal, nothing needs to be done

E007

Network is unavailable

Use KioSoft modem or check network

E008

CJSON Parse (WB returns error text)

Need to fix the data responded from the server. Please contact KioSoft team for fixing the issue, i.e. by closing Cloudflare filter.

E009

Error https

The error code may appear under the following scenarios:

1) No data response. Solution: Need to fix the data responded from the server. Please contact KioSoft team for fixing the issue, i.e. by closing Cloudflare filter.

2) Server overloaded. Solution: re-arrange the schedule to re-start the readers in batched. i.e. if we have 200 readers in total. Restart 100 readers in the morning and restart the rest devices in the afternoon.

3) No Internet available for the reader. Solution: check the internet and ensure it’s well-connected.

E010

Get Random Key failed

Use KioSoft modem

E012

Reversal failed

Chek internet

E013

No KioSoft modem

Use KioSoft modem

E014

No Modem

1.Use KioSoft modem;

2.Check that the SSID to be connected matches the router SSID

E015

Account is disabled

Go to server->Vendor Portal->Location Management to enable the account

E017

Balance is negative

Balance is insufficient. Please change a new card.

E016

Other errors

/

E018

Insufficient points

Change the payment method to balance

E019

Encrypt fails.

Encrypt key is incorrect. Generate a new key again, i.e. by re-starting the reader.

Other Codes

last 4 digits of SN

for virgin readers (display prior to the reader’s setup)

/

D-62

Waiting for Dep Key (during reader’s setup)

Tap Dep Key

Only TechTrex can perform this step. Older versions may display D-62.

F-62

Waiting for Reader Key Card

(during reader’s setup)

Tap Reader Key Card

F-61

Waiting for Machine Setup Card

(during reader’s setup)

Tap Machine Programming Card

F-60

Waiting for Site Card

(during reader’s setup)

Tap Site Card

E-51

Site Code between laundry card and Reader do not match

Laundry card and reader need to be programmed to the same site code

E-98

Value Exceeded

Reinput the value under 99.99

Lo

Balance on laundry card is lower than vend price

All readers in a laundry room should have a max value that is equal to or higher than the max value programmed in the Kiosk.

cErr

Cannot communicate with machine

Check the connections to the machine

rEbt

Start to Reboot

/

Er13

Network Testing, all WiFi signal is 0

Check Router or Internet

bUSy

Start to do NMS

/

SUCC

NMS/TMS update successfully

/

FAIL

All function failed

/

-dL-

Start to download or receive pkg

/

dlod

TMS retry

/

rSEt

Factory reset

/

rEdy

Readers receive any command from app, reader will show rEdy

/

E-44

Different vendor after tapping laundry card

1.Use the laundry card belonging to the vendor that the machine belongs to;

2.It could also be that the card was removed too quickly, try to remove the card more slowly

New Error Code

E-20

When double tap, two cards are not the same card.

Use the same card

FREE

deduct points, show free cycle

/

UnPu

Universal Pulse

/

nGD

MGD

/

TITN

TITANIUM

/

ndc

MDC

/

MIDS

ST_MIDAS

/

qUAn

CENTURION/Quantum

/

L6

ST_LG

/

COin

COINDROP

/

ntAG

MAYTAG

/

CrO5

CROSSOVER/CROSSOVER_20/CROSSOVER_ENCORE

/

Conp

COMPASS/COMPASS_W620

/

E-Le

remote profile length too large

The length of profile exceeds the maximum limit, check profile.

-btU-

bt update

/

Sev Field Issue

  1. LG Machine prices go from $1.75 to $0.10

Bug No.

#23620

Description

The LG machine was set for a $1.75 vend price, while a few days later, the price changed to $0.10.

Root Cause

The old profile from CCM is incorrect.

Solution

Set up new profiles.

  1. TWSystem Room Status Not Updating

Bug No.

#25977

Description

There are 16 readers at the location but they are not all shown up in the Room Status page.

Root Cause

The reader was artificially updated to CRPS, but the CRPS code doesn’t connect to the router.

Solution

Use the correct application.

  1. Unable to start the machine

Bug No.

#25152

Description

Start the machine with a mobile app; the reader beeps once, but the machine is not started.

Root Cause

The offline trans record is full, and the too-old version reader doesn’t support factory reset to clear the EEPROM.

Solution

Upgrade readers to a higher version

  1. Setup Failed with Laundry Signal Box Enabled in Universal Pulse

Bug No.

#28321

Description

Create a CCM profile in CleanStore, set hardware to Laundry Signal Box, set in-use signal to high or low, save the profile, and inject profile via KLM, the profile injection failed.

Root Cause

This is how it is designed.

Solution

Upgrade the reader to a version higher than 1.29.2

  1. When starting LG machine, it will prompt a price of $0 in the app and unable to start the machine

Bug No.

#23621

Description

When the coin amount is greater than or equal to the vend price, do not press the start button, and then use the APP to start, the phone will prompt the price is 0.

Root Cause

After the reader sends pulse, the reader will set the Machine Status to busy.

If the laundry machine does not change from idle to busy, the reader will not return idle.

Solution

Upgrade the reader to version 1.27.4.2

  1. Large charge on mobile transaction

Bug No.

#25404

Description

Use Hercules CP Mobile to start a machine, but the user will be randomly charged $81.92, which should be expected to be $2.25 or $2.50.

Root Cause

Machine error

Solution

Upgrade the reader to version 1.28.6.3

  1. n01 not updated when the machine goes to in use without payment

Bug No.

#22722

Description

Create a common pulse or universal pulse profile with in-use signal set to high or low, set up the reader with the profile, and then start the machine manually, the room status and N01 show “machine available”, instead of showing “cycle started”.

Root Cause

When Prime Pro or Elevate Card Connect directly detected the change from idle to busy, the uploaded N01 had a Remaining Time of 0

Solution

When the machine status changes from idle to busy, upload the Remaining Time of N01 according to the profile configuration

  1. Reader failed to start with the laundry card

Bug No.

#23453

Description

The reader is set up to accept the laundry card payment, when tapping the laundry card on the reader, the reader flashes error light and beeps and fails to start, only works intermittently.

Root Cause

The factory uses the wrong chip for the reader, for the reader with AT chip works well, only the reader with GD chip doesn’t work.

Solution

Modify usart.o to the Flash high-speed area.

  1. Whirlpool relay box causes the machine to run when overheated

Bug No.

#26032

Description

The Whirlpool dryer runs continuously long after the cycle finished, which is caused by the overheating relay box.

Root Cause

The optocoupler chip slowed down after heating. The serial timing bit became too narrow to be recognized by the AT CPU.

Solution

Add 470-ohm resistor to the yellow wire on WH140005 cable. Make sure you have heat shrink around the resistor to provide insulation.

  1. MLG27PR UI board failed after the reader installed

Bug No.

#28022

Description

After installing the readers, the dryer momentarily lost power to the UI. However, the outlet supplies steady power, and the power delivery components in the dryer also work normally. Also, it witnessed that the price was reverted to the default value but the UI board is not damaged.

Root Cause

Not found.

Solution

Upgrade the reader to version 0100.296.002.007.

For Android smartphone users, if you do not see the cycle timer counting down, please check the Allow Background Activity setting as described i